Tip of the Day: Receiving Too many symbol files from App Store Connect

If you receive a mail from App Store Connect with the message you can get help here.

You’re working with CocoaPods, right? And could it be that your Podfile contains following specification?

platform :ios, "11.0"

The whole build process works, fine. But during the upload to App Store Connect you will get a mail form Apple.

Dear Developer,
We identified one or more issues with a recent delivery for your app, “YourFantasticApp”. Your delivery was successful, but you may wish to correct the following issues in your next delivery:
Too many symbol files – These symbols have no corresponding slice in any binary [12E24350-2EDB-3EB2-9582-7BC2A490E68F.symbols, 1F287284-D399-3218-ADCD-EE1D41C29567.symbols, 30FA4B4D-642B-3C03-9AC3-682720117094.symbols, 47B86967-646F-37E6-B018-C5B3F926AD90.symbols, 5006F920-B1C4-350C-9DA3-B17C2883300C.symbols, 566EE2CA-5F7C-3751-9A4A-7C1734EAECFA.symbols, 611AD27D-D2F3-376F-878F-AF67978A37E1.symbols, 6BA0668E-0B8E-385C-B6E4-39B40C46BF04.symbols, 6BC4BC48-8EE6-3227-82DB-93AF26730D05.symbols, 94CB1823-6286-318E-BB51-203261A6BC12.symbols, 968032FF-5B45-3400-B38A-C854660333D8.symbols, 9B16B351-FB18-3030-B3DD-695672586FD5.symbols, AAF48A2D-4E69-30A4-B0FC-7B156FF79364.symbols, AFBFB6AC-8C87-3EE8-8119-F584783E6C74.symbols, B8CF7F5A-FD93-34B5-95E0-F25031CFC816.symbols, BF498176-9D0E-3117-873E-6B759C74FED6.symbols, D3524CA8-5C4B-3BC0-AFAE-3DA78260B15C.symbols, D91EC578-2483-384F-A371-31335FC48928.symbols]
After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect.
Best regards,
The App Store Team

The reason for that issue is the new iOS 11. Before iOS 11 we had to put the 32bit and 64bit Pod symbols into the archive. But after updating the deployment target to iOS 11 the 32bit Pod are not needed anymore and will be declared as duplicates.

But how can we achieve this goal?

CocoaPods can help you with a new version. Here is the issue: https://github.com/CocoaPods/CocoaPods/issues/7111

So you have to update your CocoaPods:

$ sudo gem install cocoapods --pre

You may ask why we need the parameter –pre , right? It’s because we have to update to a pre-release-version 1.6.

With the new version of CocoaPods you have to update your installed Pods now and that’s our finishing.

$ pod install

Happy Coding!

Posted in iOS

App Store References


Warning: in_array() expects parameter 2 to be array, null given in /www/htdocs/w00b3caa/dev.eynern.net/wp-content/plugins/wp-appbox/inc/getappinfo.class.php on line 1036

Warning: in_array() expects parameter 2 to be array, null given in /www/htdocs/w00b3caa/dev.eynern.net/wp-content/plugins/wp-appbox/inc/getappinfo.class.php on line 1036

Warning: in_array() expects parameter 2 to be array, null given in /www/htdocs/w00b3caa/dev.eynern.net/wp-content/plugins/wp-appbox/inc/getappinfo.class.php on line 1036

Warning: in_array() expects parameter 2 to be array, null given in /www/htdocs/w00b3caa/dev.eynern.net/wp-content/plugins/wp-appbox/inc/getappinfo.class.php on line 1036

The app was not found in the store. 🙁


The app was not found in the store. 🙁

The app was not found in the store. 🙁

The app was not found in the store. 🙁

Posted in iOS